アップデートでエラーが出るのですが

Linux Mintの初心者向けフォーラム

アップデートでエラーが出るのですが

投稿記事by hiroppy » 2016年3月05日(土) 11:59

こんにちは。

アップデートの更新をすると「http://dl.google.com/linux/chrome/deb/dists/stable/Release の取得に失敗しました 期待されるエントリ 'main/binary-i386/Packages' が Release ファイル内に見つかりません (誤った sources.list エントリか、壊れたファイル)いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。」

と言われます。私の使っているLinux Mint17.3cinnamonの入っているパソコンはDell Inspiron 5459の64bitパソコンなんですがどうしてこうなるのでしょうか?

ご教授お願いします。
アバター
hiroppy
序ノ口
 
記事: 11
登録日時: 2013年11月03日(日) 20:59

Re: アップデートでエラーが出るのですが

投稿記事by fu-sen » 2016年3月05日(土) 14:25

これは 64 ビットの環境で Google Chrome を使用している場合に表示されるようになったかと思います。
(Chromium では表示されません)
Google Chrome が 32 ビットの更新が停止されたのですが、それの影響によるものと思われます。

取り急ぎ、関連している記事をリンクしておきます。

http://www.omgubuntu.co.uk/2016/03/fix- ... ror-ubuntu

ここにはすぐに修正・改善する方法も記載があるのですが、
公式アナウンスによる修正方法ではありません。後に自動修正されるようにも思われます。
別の解決方法としては Google Chrome の派生元である Chromium に切り替える手段です。

今回の話題とは別ですが、上記にも触れているとおり、Google Chrome は 32 ビットで更新されなくなりました。
Ubuntu 12.04 LTS ベースとなっている Linux Mint 13 では 64 ビットでも更新されなくなっています。
Chromium は大丈夫のようです。または Firefox など他のブラウザをご利用下さい。
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Re: アップデートでエラーが出るのですが

投稿記事by fu-sen » 2016年3月09日(水) 13:57

Google Chrome での修正が入ってきているのですが、
まだ不完全でエラーになっていますので、具体的な手順を記載します。

/etc/apt/sources.list.d/google-chrome.list を管理者権限でテキストエディタから開き、

コード: 全て選択
deb http://dl.google.com/linux/chrome/deb/  stable main

この行 deb の後に [arch=amd64] を追加して下さい。

コード: 全て選択
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/  stable main

この代わりに端末より次のコマンドで修正する事も可能です。

コード: 全て選択
sudo sed -i -e 's/deb http/deb [arch=amd64] http/' "/etc/apt/sources.list.d/google-chrome.list"

他にも修正部分を記載しているところがありますが、本日までの更新で自動的に修正が入るようです。

数日中にインストールした場合は修正後の状態になっていますので、修正なく正常に動作します。
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40


Return to 初心者サポート

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]