CPU 動作周波数の制限が効かない

Linux Mintのハードウェアに関する質問

CPU 動作周波数の制限が効かない

投稿記事by Mintia » 2018年7月12日(木) 23:23

Intel(R) Core(TM) i5-3360M CPU @ 2.80GHz を使用。

ブーストの設定は何も触っていないのに、
基本ブーストしている状態で常にTemperature が70℃〜80℃ある状況なので、
cpufreq で governors を powersave にしましたが、動作が変わらず、
current policy: frequency should be within 1.20 GHz and 1.20 GHz.
にして上限を絞っても、普通に上限を超えてきます。

$ cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 0.97 ms.
hardware limits: 1.20 GHz - 3.50 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 1.20 GHz and 1.20 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency is 3.31 GHz.
analyzing CPU 1:
driver: intel_pstate
CPUs which run at the same hardware frequency: 1
CPUs which need to have their frequency coordinated by software: 1
maximum transition latency: 0.97 ms.
hardware limits: 1.20 GHz - 3.50 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 1.20 GHz and 1.20 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency is 3.31 GHz.
analyzing CPU 2:
driver: intel_pstate
CPUs which run at the same hardware frequency: 2
CPUs which need to have their frequency coordinated by software: 2
maximum transition latency: 0.97 ms.
hardware limits: 1.20 GHz - 3.50 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 1.20 GHz and 1.20 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency is 3.31 GHz.
analyzing CPU 3:
driver: intel_pstate
CPUs which run at the same hardware frequency: 3
CPUs which need to have their frequency coordinated by software: 3
maximum transition latency: 0.97 ms.
hardware limits: 1.20 GHz - 3.50 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 1.20 GHz and 1.20 GHz.
The governor "performance" may decide which speed to use
within this range.
current CPU frequency is 3.32 GHz.

改善方法をご存知でしたらご教示お願いいたします。
Mintia
前相撲
 
記事: 1
登録日時: 2018年7月12日(木) 23:01

Re: CPU 動作周波数の制限が効かない

投稿記事by nandekana » 2018年7月18日(水) 08:28

Mintia 様 はじめまして

Mint17.xか18.xか19か不明で
DEがXfce4かMATEかCinnamonかKDEか不明
19ならまだ不安定かな?Mint19 MATE 64bitで起動しないweb browserが有りました。
19にはKDEは無いようです。

Debian stable派生のLMDE2も有りました。

私の経験ですがMint13 MATE 64bitの時、OS起動でアプリを何も起動しない状態で
CPU負荷が常時60%位で1ケ月経っても改善しなかったので、他のディストリビューションもインストールして
それを使用していました。”おれ環境”のせいだったのかも?

ご参考用で

Debian9派生 CPUのクロックの変更
/etc/default/cpufrequtils というファイルを作る
内容は下記

GOVERNOR=powersave

で保存でPCを再起動か
コマンドと実行結果
sudo /etc/init.d/cpufrequtils restart

上記コマンドでPCの再起動が不要かも?

Debian9派生でDEはMATEで実際にやった事有りです
GOVERNOR=ondemand にしないと私のPCではweb browserとかで
遅くて使い物に成りませんでした。

ソースらしき物
CPUの動作周波数をコントロールする - Linux Mintのメモ
https://sites.google.com/site/linuxnome ... ufrequtils
右記 https://sites.google.com/site/linuxnomemo/mint-setting/cpufrequtils
nandekana
幕下
 
記事: 89
登録日時: 2014年9月01日(月) 06:00


Return to ハードウェア

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]