canon LBP6330の設定方法について

Linux Mintのハードウェアに関する質問

canon LBP6330の設定方法について

投稿記事by gostraight » 2015年11月02日(月) 17:26

canon LBP6330の設定方法について

linux mint17.2(64bit)でプリンタcanon LBP6330を利用しようとしています。
→http://cweb.canon.jp/satera/lbp/lineup/a4-mono/6340-6330/spec.html
canonのlinuxドライバのページ(Linux 対応状況(レーザビームプリンタ))
→http://cweb.canon.jp/e-support/faq/answer/lbp/27987-1.html
で、LBP6330の系列のLBP6300にしたがってインストールしようと試みました。
LBP6300
→http://cweb.canon.jp/satera/lbp/lineup/a4-mono/6300/
その中で、マニュアルにあるとおり
「プリントスプーラにプリンタ(PPD)を登録します。」
として
/usr/sbin/lpadmin -p LBP6330 -m CNCUPSLBP6300CAPTJ.ppd -v ccp://localhost:59687 –E
と実行すると、
lpadmin: "–E" は未知の引数です。
とでてきます。
解決方法をご存知でしたらご享受ください。
gostraight
前相撲
 
記事: 7
登録日時: 2015年10月31日(土) 23:25

Re: canon LBP6330の設定方法について

投稿記事by はっくん » 2015年11月02日(月) 17:41

/usr/sbin/lpadmin -p LBP6330 -m CNCUPSLBP6300CAPTJ.ppd -v ccp://localhost:59687 –E

において,emacs で c-u c-x = で文字の詳細を調べてみました.

「-p」の「-」は
preferred charset: ascii (ASCII (ISO646 IRV))
code point in charset: 0x2D
であり,
「–E」の「–」は
preferred charset: unicode-bmp (Unicode Basic Multilingual Plane (U+0000..U+FFFF))
code point in charset: 0x2013
となりました.

「E」の前のハイフンを全角文字で入力していませんか?
Linux Mint 17.3 Cinnamon 64-bit
Cinnamon Version 2.8.6
Linux Kernel 3.19.0-32-generic
Core2 Quad Q9550
NAVIDIA GeForce GT710[PCI-Express 2.0(x16)]
NAVIDIA GeForce GT610[PCI-Express 2.0(x1)]刺さっているだけ
はっくん
幕下
 
記事: 95
登録日時: 2013年11月06日(水) 22:44

Re: canon LBP6330の設定方法について

投稿記事by gostraight » 2015年11月02日(月) 21:04

 ご指摘の通り、全角でした。
 なお、本件canonのインストールページを貼り付けました。
同様の作業をされた方は、同じような現象が起きるかもしれません。
 なお、プリンターのインストールについては、まだうまく行っておらず
試行錯誤しているところです。
 ありがとうございます。
gostraight
前相撲
 
記事: 7
登録日時: 2015年10月31日(土) 23:25

Re: canon LBP6330の設定方法について

投稿記事by gostraight » 2015年11月02日(月) 23:08

 Linux Mint(64bit)でcanon LBP6330をネットワークプリンター(ipアドレス割り当て)で利用されておられる実績をお持ちの方はいらっしゃいますか。
 その際参考にされたページやエラー等の回避について情報がございましたら教えていただければありがたいです。
 設定がうまくゆかないという資料はあるようなのですが、成功したという資料がLBP6330については見当たらないように思えます。
質問の仕方が適切でないですが、お許しください。
gostraight
前相撲
 
記事: 7
登録日時: 2015年10月31日(土) 23:25

Re: canon LBP6330の設定方法について

投稿記事by nandekana » 2016年6月12日(日) 11:37

gostraight 様
canon LBP6330の設定方法について
御参考用で
今のdriverが落とせる所は下記のようです。

CAPT Printer Driver for Linux Ver.2.70(64bit)
http://cweb.canon.jp/drv-upd/lasershot/ ... uxx64.html

で、printerのdriverと言う物は元が不確かですが、どうも32bitで出来ているようです。
なのでia32-libsをインストールしておく必要が有ると思います。
Ubuntu14.04 64bitにはia-32libsは無いのですが
Mint17.x  64bitにはia32-libsは有ります。
nandekana
幕下
 
記事: 83
登録日時: 2014年9月01日(月) 06:00


Return to ハードウェア

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]