acpi=offを使用しないと電源が切れる

Linux Mintのハードウェアに関する質問

acpi=offを使用しないと電源が切れる

投稿記事by tm_ion » 2021年2月03日(水) 10:50

私はThinkpad A285 Ryzen 5Pro 2500Uを持っています。

Linux mint 20をインストールしていますが、acpi=offを使用しないと起動できない または 電源が切れる問題が起きています。
これまでのインストールからの大まかな経緯は以下の通りです。

・USBでLinux mint 20を起動しようとしてもできなかったので、acpi=offを使用して起動し、インストールをした(legacy bios)
・acpi=offを使うとバッテリー残量が見れないなどの問題があるので、他のパラメーターを複数試してみたところ、
運良く起動できるときもあるが、使用中に急に電源が切れる
※他のパラメーター:acpi=ht,acpi=oldboot,iommu=soft,iommu=pt,irvs関係,amd_iommu=pt ivrs_ioapic[32]=00:14.0
intremap=off spec_store_bypass_disable=prctl,idle=nomwait 他多数を試していますが起動するときがあっても必ずしばらくして電源が落ちます。

・acpi=offを使用しているときは、必ず起動が成功するし、途中で電源が切れることはない
・BIOSアップデートをしてみたけど改善しない(LENOVOサイトからダウンロードできる最新版)※2020年6月頃のもの
・amdgpuドライバーをインストールしたところ、dkms関連の一部エラーが出て失敗した
失敗はしたものに、一時期は安定して起動しているように見えたが、その後同じ症状が現れてしまう
・kernelをバージョン下げてみたりあげてみたりしてもだめ(5.4、5.8、5.10)
・kernelのCONFIGからACPIを無効にしてコンパイルすると正常に動作する
・kernelのCONFIGからACPIを有効にして、関連する項目をバッテリー、ACアダプター以外を無効にしてコンパイルしても落ちる(または起動しない)
※添付画像は一例です。

・MX Linux(MX-19.3 x64 “ahs”)をインストールしてみたが同じ症状が出た
・Windows 10のインストール用USBをUEFI起動を試すとやはり途中で電源が切れる
・画面に表示されるエラーは複数ある acpi=offを使わないときだと以下のエラーが表示

コード: 全て選択
platform usbc000:00 failed to claim resource 0
acpi usbc000:00: platform device creation failed -16


以上になります。

dmesgのログは正常に起動したときしかみれず、どれを参考にして良いのかわからないのですが、
おそらくacpi PNP関連でもエラーが出ていたように思います。

目的はacpi=offを使わずに安定して起動できるようになるか、
またはacpi=offを使いながら、バッテリーの残量を見ることができるようにすることです。

尚、同内容を海外版にも記載していますが、こちらにも加筆して再投稿させてもらっています。
お力を貸していただければ幸いです。
添付ファイル
2021020209_53_23_001.png
2021020209_53_23_001.png (167.71 KiB) 表示数: 56 回
tm_ion
前相撲
 
記事: 1
登録日時: 2021年2月03日(水) 10:37

Return to ハードウェア

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]