LMDEにLXDEを入れたらMATEでエラー

Linux Mintのソフトウェアとアプリケーションに関する質問

LMDEにLXDEを入れたらMATEでエラー

投稿記事by kaoru » 2012年12月20日(木) 23:02

LMDEにLXDEを入れたのですが、MATEに切り替えてログインしなおしてみたらエラーメッセージが出るようになってしまいました。
数日間色々ネット検索してみたのですが、どうも解決方法にたどり着くことができません。
どなたかお知恵をお貸し下さいませ。

状況ですが、MATEで起動すると真っ先に以下のエラーが出ます。しかしエラーがでるだけで今のところ動作に支障はないようです。
GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
LXDEやCinnamonでログインしてもエラーが出ません。
直す方法はありますでしょうか?

私はlinux初心者なのですが、楽しく試して壊して何回もインストールし直ししていますので、色々試させてください。
インストールし直しになっても全然大丈夫です。
kaoru
序二段
 
記事: 22
登録日時: 2012年11月07日(水) 01:27

Re: LMDEにLXDEを入れたらMATEでエラー

投稿記事by luyikei » 2012年12月23日(日) 11:35

luyikeiです。

http://www.pclinuxos.com/forum/index.php?topic=101160.0
The solution is so go into "Preferences->Desktop Session Settings" and un-check "PolicyKit Authentication Agent" as LXDE runs it's own LXPolKit Authentication Agent instead of polkit-gnome now.


私の環境にはLXDEは入っていないため日本語ではどう表示されるかは未確認ですがおそらく

"設定->デスクトップセッションの設定"を開き"PolicyKit 認証エージェント"のチェックを外す
という事です。


こちらのページを参考にしてやってみてください。
http://yasshan.way-nifty.com/lubuntu/2010/05/index.html
アバター
luyikei
管理人
 
記事: 168
登録日時: 2012年6月02日(土) 11:02

Re: LMDEにLXDEを入れたらMATEでエラー

投稿記事by kaoru » 2012年12月25日(火) 01:46

luyikei 様
ご返答ありがとうございます。
自分でも探していたのですがなかなか回答にたどりつくことができずにいました。

おかげさまでエラーが出なくなりました。

>"設定->デスクトップセッションの設定"を開き"PolicyKit 認証エージェント"
にはチェックが入っていない状態だったのですが、もしやと思いチェックを入れなおしてみたところ(チェックを入れて「OK」をクリック、次はチェックを外して「OK」をクリック)、
MATEでログインしなおしてもエラーが出なくなりました。

本当にいつもありがとうございます。
kaoru
序二段
 
記事: 22
登録日時: 2012年11月07日(水) 01:27


Return to ソフトウェアとアプリケーション

オンラインデータ

このフォーラムを閲覧中のユーザー: Google [Bot] & ゲスト[1人]

cron