LinuxMint17.3 Xfce / X64 ブートリペアーで修復出来ない

Linux Mintのソフトウェアとアプリケーションに関する質問

LinuxMint17.3 Xfce / X64 ブートリペアーで修復出来ない

投稿記事by mitchi » 2016年7月04日(月) 16:33

今日は  私は Win10 と linux/ubuntu をマルチブートで 新しいMint18 cinnamon使わせて頂きましたが何かしっくり来ないとこがあり
(ubuntu16.04 + cinnamon3.0.5 でも同じでしたが ログインが出来なくなってしまったり ・・パスワード受け付けない ・・
 再起動後 壁紙がなくなり 真っ黒の画面で フォントが ちっちゃくなり変更出来ない?)
そこで17.3 Xfce にgrubを戻したく liveDVD で boot-repairを install し修復しましたが
最後のほうで ”こわれたカーネルパッケージ 3.13.0.86 XXX があります・・・・ grubは無くなりました・・・・”
で修復出来ませんのでリカバリしかありません
Mint18 cinnamonでは しっかりgrub修復可能です
私がMin17.3 Xfce をインストールしたあとはカーネル 3.19.0 32 でしたし 3.13.0.86 なんて入れていません
synaptic で破損パッケージを検索しても何も有りません

なんとか解決方法をご教示して頂きたくお願いいたします
mitchi
序ノ口
 
記事: 10
登録日時: 2014年10月05日(日) 13:25

Re: LinuxMint17.3 Xfce / X64 ブートリペアーで修復出来ない

投稿記事by fu-sen » 2016年7月05日(火) 09:03

たしか、カーネルを更新してましたよね? (他の方へ、環境などはこちらに記載されています)

LinuxMint17.2 ISO/USB 起動できない
viewtopic.php?t=1524

Linux Mint 17.3 のカーネルは「独自に更新していなければ」、
Ubuntu 14.04 LTS に依存されるので、 3.13 系になっています。

http://packages.ubuntu.com/trusty/linux-generic

カーネルの更新が原因で boot-repair が復旧に失敗している可能性が高いです。

GRUB 2 関連の復旧方法、自分の別サイトでメモ書きしてあります。

http://installlinux.jimdo.com/linux-%E3 ... A2/grub-2/

「Super Grub2 Disk」が使えるかもしれません。

18 KDE・Xrce は7月下旬〜8月上旬頃に公開されます。
この辺が解決困難な場合、中旬にベータ版が出るので、それをインストールしてしまうのも手です。
パッケージ更新すれば正式版同等にできます。ベータ版なので、不具合が多い可能性にご注意下さい。

ただし、Ubuntu 16.04 LTS+Cinnamon、Linux Mint 18 Cinnamon の問題がカーネル依存の問題である可能性があり、
18 Xfce でも同じ問題が発生する可能性がありそうです。現状なら 18 MATE でこの確認が行えるでしょう。
英語コミュニティで機種依存の情報が得られるかもしれません。
何か同じような報告を Ubuntu か Linux Mint のコミュニティで見た記憶があります。
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Re: LinuxMint17.3 Xfce / X64 ブートリペアーで修復出来ない

投稿記事by mitchi » 2016年7月05日(火) 12:58

Fu-sen様 ありがとうございます
>> たしか、カーネルを更新してましたよね >>
いいえ、17.3 Xfce DVD.iso からのクリーンインストールでも発生します
この場合 初めから カーネルは 3.19.XXX でインストールされます
途中で 3.13.XXXが 3.19.XXX にアップグレードされているんでしょうかね?

ですから >>Linux Mint 17.3 のカーネルは「独自に更新していなければ」、
Ubuntu 14.04 LTS に依存されるので、 3.13 系になっています >>
ということは、私には 当てはまらない と思います

まあ ”おま環” 臭い感じが多い です最近
(cinnamon 3.0.5 nvidiaグラボ臭い? GT635 なんです)
(peppermint7 は どうにもこうにも 途中でコケテ ログイン出来なくなってしまう)
(kernel 4.4.13 はdebファイルからインストールしても VGA画面しかならない
 mint-updateからは すんなり 4.4.28 が入って VGA以上の FHD(??) が選択できる)

そこで mint18/cinnamon は しっかりブートリペアーで 修復出来ますので
時期 mint18/Xfce に期待しています
<< Super Grub2 Disk >>  こんな厄介はご勘弁を・・・ ですので
泥臭く リカバリで(全くgrubが汚れて マンドクセエエ 状態です)対応も疲れたので
安定なディストリ KLUE2.0 jack / WattOS -R9  これらは UEFI起動じゃなくlegacy mode なので grubが汚れない
         Voyager16.04 UEFI mode で ブートリペアー修復可能
に 逃げました
ご対応・情報 ありがとうございました
mitchi
序ノ口
 
記事: 10
登録日時: 2014年10月05日(日) 13:25


Return to ソフトウェアとアプリケーション

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]

cron