ソフト(chrome)インストールの際に「broken dependencies」

Linux Mintのソフトウェアとアプリケーションに関する質問

ソフト(chrome)インストールの際に「broken dependencies」

投稿記事by zazaza » 2014年6月03日(火) 16:22

こんにちは。
お世話になります。

早速Mint17(64bit)をインストールいたしました。
chromeを愛用しているので、chromeのウェブページに移動して、そこからUbuntuバージョンを選択しました。
インストールが完了しかけのときに
「broken dependencies」
との表示がでて完了しませんでした。
Menu→InternetのところにChromeのアイコンが使いされましたが、ポチってみてもなんの反応も有りませんでしたので、
やはりインストールできてないようです。
もちろんFireFoxは起動できます。

どのようにすればこの問題を解決できるのでしょうか?
よろしくお願いします。
zazaza
前相撲
 
記事: 9
登録日時: 2014年6月03日(火) 16:05

Re: ソフト(chrome)インストールの際に「broken dependencies」

投稿記事by ban » 2014年6月04日(水) 08:54

やってみました。

ソフトウェアアップデートをせずに google-chrome-stable_current_amd64.deb をインストールしようとすると、確かに broken dependencies となり、インストールに失敗しました。次にアップデートマネージャからソフトウェアアップデートをしてからインストールすると成功しました。

追記1
Chrome は 32bit バージョンと 64bit バージョンがあるので間違えないよう注意してください。

追記2
パッケージインストーラにおそらくバグがありますね。インストール成功でも失敗でも、ウィンドウを閉じることができません。

追記3
Chrome と互換性のあるブラウザで Chromium というのがあります。Synaptic パッケージマネージャからインストールできます。こちらの方が良いかもしれません。Chromium についてはこちらをご参照ください。
http://ja.wikipedia.org/wiki/Chromium
Hiroaki Ban
Linux Mint 16 Perta KDE 64bit
端末入力を楽にする3つの小技
http://forums.linuxmint-jp.net/viewtopic.php?f=10&t=1178
ban
幕下
 
記事: 75
登録日時: 2013年11月04日(月) 01:41

Re: ソフト(chrome)インストールの際に「broken dependencies」

投稿記事by zazaza » 2014年6月04日(水) 15:19

わざわざ試してもらったみたいでありがとうございます。
感謝です!

インストールしたのは64Bit版です。
やはりなんかしらのエラーが有るようですね。

ChrominiumはLinuxのソフトストアのようなもので有りましたね。
クロームのパクリかと思っていましたが、随分と良さそうです。
こちらをMintでは使っていきたいと思います。
いいものを教えてもらってありがとうございます。
zazaza
前相撲
 
記事: 9
登録日時: 2014年6月03日(火) 16:05

Re: ソフト(chrome)インストールの際に「broken dependencies」

投稿記事by fu-sen » 2014年6月04日(水) 17:57

Chromium は Google Chrome のベースとなっているブラウザになります。
バージョン表記も基本的に共通します。
ちょっと表示とかに違いはありますが……
容易に導入でき、バージョン更新はアップデートマネージャーで更新されるため、
Linux ではむしろ Chromium の方が使われているかもしれません。

Google Chrome・Chromium 共に共有ライブラリがシビアで、問題が発生するケースも生じていて、
特に最近リリースしているバージョンが影響が出ているようなので、その辺が関係しているかもしれません。
(今 Debian の一部では Chromium の公開を止めている位です :x )
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Re: ソフト(chrome)インストールの際に「broken dependencies」

投稿記事by zazaza » 2014年6月05日(木) 12:51

ChromeとLinuxは相性がいまいちだと考えても良さそうですね。
ただ、Windows機等との同期機能は最高なので、
Chromiumのほうをとりあえずインストールしてみます。
度々の解答どうもありがとうございました。
zazaza
前相撲
 
記事: 9
登録日時: 2014年6月03日(火) 16:05

Re: ソフト(chrome)インストールの際に「broken dependencies」

投稿記事by fu-sen » 2014年6月08日(日) 15:10

いいえ。
タイミング悪く、今の状態がバグが沢山でている状況です。 :x
こんな状態になっているのは、今まで経験していないです。

ちょっと詳しくいうと、
Google Chrome は 35 にバージョンアップして公開されているのですが、
Chromium は Ubuntu パッケージがまだ 34 を公開し続けています。
通常 Chrome が公開されると Chromium も数日中に同じバージョンに合わせるのですが、
どうも問題が発生しているようで、35 への更新が遅れています。
(LMDE の Chromium は安定度重視で 31 から更新していないようです)

ここ数日 Chrome・Chromium 関連のバグ報告を目立って見ているので、
今 Chrome を導入しようと考えている人はご注意下さい。
Chrome のインストール・動作で何か問題が発生している場合は、
一時的でも Chromium にしてみると改善するかもしれません。
ただし、これは今に限った一時的なものだと思って下さい。
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40


Return to ソフトウェアとアプリケーション

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]