screem-0.16.1.tar.gzファイルのインストール

Linux Mintのソフトウェアとアプリケーションに関する質問

screem-0.16.1.tar.gzファイルのインストール

投稿記事by momotarou421 » 2014年1月03日(金) 17:13

こんにちは :)
htmlエディターの screem-0.16.1をインストールしようと思い
tar.gzファイルをDL :D
そしてターミナルで
$ tar zxvf screem-0.16.1.tar.gz
$ cd screem-0.16.1
$ ./configure
までは順調に行った(と思う)のですが :shock: :shock:
$ makeを入力したら :?: :?: :?:

make: *** ターゲットが指定されておらず, makefile も見つかりません. 中止. :cry:
と出ます。

フォルダを見るとscreem-0.16.1フォルダが出来ていてその中にMakefile.inが出来ています。
インストールするにはどうしたらいいでしょう。
宜しくお願いします。
momotarou421
序ノ口
 
記事: 15
登録日時: 2013年5月31日(金) 21:31

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by sawakaze » 2014年1月03日(金) 19:13

さわかぜです
./configure でエラーはでてませんか?

もし差支えがなければ./configure の結果を貼っつけていただけると嬉しいです
----
Sawakaze
Linux Mint Debian Edition
Email : souichirho@gmail.com
WebPage : http://www.sawakaze.net/sishikawa/
sawakaze
幕下
 
記事: 60
登録日時: 2013年6月11日(火) 20:56
お住まい: Aichi

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by momotarou421 » 2014年1月03日(金) 19:40

さわかぜさん早速の返信ありがとうございます。

エラー出てました。

configure: error: XML::Parser perl module is required for intltool

宜しくお願いします。
momotarou421
序ノ口
 
記事: 15
登録日時: 2013年5月31日(金) 21:31

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by sawakaze » 2014年1月03日(金) 20:25

さわかぜです

libxml-parser-perl か intltool がご使用の環境に入っていない時に提示していただいたエラーが出るかもしれません。
上記パッケージがインストールされていることを確認して、もし入っていない場合はパッケージをインストールしてください。
----
Sawakaze
Linux Mint Debian Edition
Email : souichirho@gmail.com
WebPage : http://www.sawakaze.net/sishikawa/
sawakaze
幕下
 
記事: 60
登録日時: 2013年6月11日(火) 20:56
お住まい: Aichi

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by momotarou421 » 2014年1月03日(金) 21:34

さわかぜ様お世話になります。
確認しましたが
libxml-parser-perl も intltool(intltool-debian)もインストールされていました。

宜しくお願いします。
momotarou421
序ノ口
 
記事: 15
登録日時: 2013年5月31日(金) 21:31

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by ban » 2014年1月04日(土) 06:47

横から失礼します。

Linux Mint 16 KDE 64bit でコンパイルを試みましたが、結論から言うと screem のインストールは諦めたほうが良いと思います。
configure: error: XML::Parser perl module is required for intltool

このエラーは libxml-parser-perl をインストールすることでクリアしましたが、その後も依存パッケージがたくさんあり、どうしても解決できないもう廃止されたパッケージが2つあり、ネットで調べてみた所この解決はほとんど不可能なようです。

英文ですがこれを読んでみてください。
http://askubuntu.com/questions/226564/how-to-install-screem-in-ubuntu-12-10
これとこれからのリンクの記事によると screem 自体もう何年も放置されており、すでに2011年の時点で廃止された依存パッケージがインストールできないため、インストールを断念したとあります。

実際に自分でやってみましたが、廃止されたパッケージは以下の2つで、synapticパッケージマネージャよりインストールできませんでした。
No package 'libgtkhtml-2.0' found
No package 'gtksourceview-1.0' found

そこで libgtkhtml-2.0 についてはソースをダウンロードしてコンパイルを試みましたがエラーが出たので、検索して上記のリンクの記事に行き当たりました。

おそらくこれらの問題を解決してなんとかインストールできたとしても screem 自体が古くメンテナンスされていないので、実用に耐えるとは考えにくいです。
ですので諦めて別のソフトを探したほうが良いと思います。



一応自分でやったことを書いておきます。

1番目のエラー
./configure
メッセージ前略
checking for gcc... gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

g++ をインストールして解決

2番目のエラー
./configure
メッセージ前略
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

libxml-parser-perl をインストールして解決
momotarou421さんの環境にはインストールされていたということですが、私の環境ではインストールされておらず、インストールしたら解決しました。

3番目のエラー
./configure
メッセージ前略
configure: error:
*** GLIB 2.5.6 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.

libglib2.0-dev をインストールして解決。

4番目のエラー
./configure
メッセージ前略
No package 'gtk+-2.0' found
No package 'libgnome-2.0' found
No package 'libgnomeui-2.0' found
No package 'libxml-2.0' found
No package 'libglade-2.0' found
No package 'gconf-2.0' found
No package 'gnome-vfs-2.0' found
No package 'gdk-pixbuf-2.0' found
No package 'libgtkhtml-2.0' found
No package 'libgnomeprint-2.2' found
No package 'libgnomeprintui-2.2' found
No package 'gtksourceview-1.0' found
No package 'libgnome-menu' found


そこで以下のパッケージをインストール。(インストールの時は通常 -dev のついたバッケージ、つまり開発用パッケージが必要。)
libgtk2.0-dev
libgnome2-dev
libgnomeui-dev
libglade2-dev
libgnomeprint2.2-dev
libgnomeprintui2.2-dev


するとかなりエラーは減りましたが、以下のパッケージは新しいバージョンしかなく、新しいバージョンをインストールしても以下のエラーが残りました。
No package 'libgtkhtml-2.0' found
No package 'gtksourceview-1.0' found


そこで libgtkhtml-2.0 のソースを探してインストールを試みた所、configure は通りましたが make でエラーが出ました。
エラーメッセージは長いので省略しましすが、検索したところ上記のリンクの記事が出てきて、コンパイルを断念しました。
Hiroaki Ban
Linux Mint 16 Perta KDE 64bit
端末入力を楽にする3つの小技
http://forums.linuxmint-jp.net/viewtopic.php?f=10&t=1178
ban
幕下
 
記事: 75
登録日時: 2013年11月04日(月) 01:41

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by sawakaze » 2014年1月04日(土) 09:38

さわかぜです

banさん フォローありがとうございます。
私もLMDE で./configureを試し libgtkhtml2 が超えられない壁になっていました(笑)
一応以下でなんとかなりそうでしたが、パッケージの内容を見て導入をやめました。
http://archive.debian.net/etch/libgtkhtml2-0

momotarou421 さんへ

banさんのおっしゃることは ごもっともかもしれません。
SCREEM 自体は近頃メンテナンスされた形跡はありません。
また、そのソフトウェアを構成する為のライブラリが古く、メンテナンスされていないものが多いのが事実です。
あまり私はSCREEM の導入はオススメしません。

Linuxで使用できる便利なHTMLエディターを探していると私は思っています。
もし、SCREEMじゃないといけないという理由がありませんでしたら、以下のソフトウェアを使うという選択肢も有ります。

[1] bluefish
http://bluefish.openoffice.nl/index.html

[2] bluegriffon
http://bluegriffon.org/
----
Sawakaze
Linux Mint Debian Edition
Email : souichirho@gmail.com
WebPage : http://www.sawakaze.net/sishikawa/
sawakaze
幕下
 
記事: 60
登録日時: 2013年6月11日(火) 20:56
お住まい: Aichi

Re: screem-0.16.1.tar.gzファイルのインストール

投稿記事by momotarou421 » 2014年1月04日(土) 10:32

さわかぜさん、banさんありがとうございました。
さわかぜさんの提案を試してみます。
言われているようにscreemに固執しているわけではないので。
お騒がせしました。
momotarou421
序ノ口
 
記事: 15
登録日時: 2013年5月31日(金) 21:31


Return to ソフトウェアとアプリケーション

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[3人]

cron