【自己解決済】Skypeでスピーカーとマイクが同時に使えない

Linux Mintのソフトウェアとアプリケーションに関する質問

【自己解決済】Skypeでスピーカーとマイクが同時に使えない

投稿記事by ペッカム » 2017年11月20日(月) 16:25

初心者です。お世話になります。
スカイプで通話をしようとするとスピーカーとマイクが同時に使えない為、どなたか解決法をご教示願います。

●PCの情報、周辺機器、使用ソフトなど
【OS】Linux Mint 17.3 Cinnamon 64-bit
【Cinnamonバージョン】2.8.8
【マザーボード】ASRock H110M-HDV
【スピーカー(外部)】Dell AC511 サウンドバー
【マイク】iBUFFALO マイクロフォン スタンドタイプ BSHSM06WH(マイク自体はICレコーダーに繋いで使用した際問題なく使えたので故障はしていません)
【Skypeアプリ】Skypeforlinux 8.10.0.4
【音量調節関係でインストールしているソフト】GNOME Alsa Mixer、pavucontrol(スタートメニューでの名称はPulseAudio音量調節になっています)
【備考】モニター(VGA端子)とパソコン(HDMI端子)を変換ケーブルで繋いでいます。
モニターにはスピーカーがついていないため、外部スピーカーを使用しています。

●やったこととその結果
わからないなりに調べて色々と試してみました。無意味な行為も多いと思います。

・マイクを外部スピーカーのマイク端子に接続→サウンドの設定→入力タブ→入力の音量をオンにしてからマイクに向かって喋る
結果…「Digital Input(S/PDIF)」「ラインイン」どちらとも音量ゲージが無反応

・マイクを外部スピーカーのマイク端子に接続→Skype音声テストを行う
結果…スピーカーから音が出ない

・Skype音声テストの途中でマイクを外部スピーカーのマイク端子に接続
結果…マイクを接続した瞬間、スピーカーから音が出なくなる

・Skype音声テストの途中でマイクを外部スピーカーのマイク端子に接続し、イヤホンを外部スピーカーのイヤホン端子に接続
結果…同じく音が聞こえず
そのあとイヤホンを抜いたところ、ザーという音がずっと続いたため、サウンド設定でサウンドの出力先を一旦「アナログ出力」→「デジタル出力(S/PDIF)」にしてからやっと収まりました。

・Skype→ツール→オーディオとビデオの設定→マイクとスピーカー:「Dell AC511 USB SoundBar,USB Audio」、または「default device」に設定→前述の3つのやり方でSkype音声テストを実行
結果…どちらともマイクを接続した瞬間スピーカーから音が出なくなる
※日によってマイクのみ「Dell AC511 USB SoundBar,USB Audio」の選択肢が消えるのも謎です。

・PulseAudio音量調節→録音タブ→外部スピーカーに設定
「Dell AC511 USB SoundBar デジタルステレオ(IEC958)」
「Monitor of Dell AC511 USB SoundBar デジタルステレオ(IEC958)」
結果…両方試してみてもやはりマイクを接続するとスピーカーから音が出なくなる

・システム管理→ドライバマネージャ→「xserver-xorg-video-nouveau(open-source)」から「nvidia-384」に変更(選択肢はこの2つのみでした)→再起動
結果…この状態でもやはりマイクを接続した途端にスピーカーから音が出なくなる
あと、タスクバーが表示されなくなる、インターネットブラウザのウィンドウの大きさを変えられないなどの不具合も起こったので、できれば「xserver-xorg-video-nouveau(open-source)」の状態で解決したいです

・オーディオデバイスの確認とその優先順位の変更
オーディオデバイスの確認:
コード: 全て選択
$ cat /proc/asound/modules


    0 snd_hda_intel
    1 snd_hda_intel
    2 snd_usb_audio
このような結果になりました。
2 snd_usb_audioが恐らく外部スピーカーのことだからこれを一番上に持っていけばいいのかなと思い、以下のコマンドで優先順位を変更しようとしました。

優先順位変更:
コード: 全て選択
$ sudo /etc/modprobe.d/alsa-base.conf


    sudo: /etc/modprobe.d/alsa-base.conf: command not found
alsa-base.confがないという結果になり変更ができませんでした。

・いくつかのサイトに倣いalsa-base.confに代わるファイルを作成
コード: 全て選択
$ sudo vi /etc/modprobe.d/sound.conf

そのあと、外部スピーカーを再優先にするため以下のように入力しようとしたのですが
    options snd_usb_audio index=0
    options snd_hda_intel index=1
    options snd_hda_intel index=2
1行目と2行目の間に改行が入ってしまったので再度ファイル作成からやり直そうとしたところ、以下のエラーが出ました。

    E325: ATTENTION
    Found a swap file by the name "/etc/modprobe.d/sound.conf.swp"
    owned by: root  dated:(省略)
    modified: YES
    user name: root  host name:(省略)
    process ID:(省略)
    While opening file "/etc/modprobe.d/sound.conf"

    (1) Another program may be editing the same file.
    If this is the case, be careful not to end up with two different instances of the same file when making changes. Quit, or continue with caution.
    (2) An edit session for this file crashed.
    If this is the case, use ":recover" or "vim -r /etc/modprobe.d/sound.conf" to recover the changes (see ":help recovery").
    If you did this already, delete the swap file "/etc/modprobe.d/.sound.conf.swp" to avoid this message.

    "/etc/modprobe.d/sound.conf" [New File]
    Press ENTER or type command to continue
PCを再起動しても同じ結果でした。
一旦swapファイルの削除をし再度やり直そうとしましたが、なぜか編集ができなくなっていたので次の方法でオーディオデバイスの優先順位を変えることにしました。

・以下のコマンドでテキストエディタから直接編集→保存→再起動
コード: 全て選択
$ sudo gedit /etc/modprobe.d/sound.conf

テキストエディタには外部スピーカーが最優先されるように
    options snd_usb_audio index=0
    options snd_hda_intel index=1
    options snd_hda_intel index=2
と記載
結果…外部スピーカーがパソコンに認識されませんでした。
試しにindex=1にしてみても同じ結果でした。
index=2の状態じゃないと認識されないようです。

これ以上は手詰まりの状態です。
どなたか解決法をご存知の方がいれば教えていただきたいです。
間違っている部分や情報不足の部分もあると思いますので、その際はご指摘ください。
以上、お願いいたします。
最後に編集したユーザー ペッカム [ 2017年12月01日(金) 13:45 ], 累計 1 回
ペッカム
前相撲
 
記事: 6
登録日時: 2017年3月25日(土) 20:54

Re: Skypeでスピーカーとマイクが同時に使えない

投稿記事by ペッカム » 2017年12月01日(金) 13:43

自己解決しました。
パソコン背面側の端子にマイクを接続して音声テストを行ったところ、スピーカーとマイクを同時に使用できました。
ペッカム
前相撲
 
記事: 6
登録日時: 2017年3月25日(土) 20:54


Return to ソフトウェアとアプリケーション

オンラインデータ

このフォーラムを閲覧中のユーザー: Bing [Bot] & ゲスト[2人]

cron