グラフィックカード関連の問題(インストールから初回起動まで)

Linux Mintのインストールと起動に関する質問

グラフィックカード関連の問題(インストールから初回起動まで)

投稿記事by s98545sm » 2014年4月08日(火) 22:16

「ハードウェア」で質問するかこちらにするか迷いましたが、
特に初回起動に特化した話のためこちらで質問させていただきます。

isoを焼いたインストールDVDでのお試し、インストールまでは順調であったハードウェア構成であるにも関わらず、
インストール後、正常に起動できません。
Linux Mint MATE16 32bitです。

症状に特徴があります。
1、オンボードの画面出力からの場合、正常起動可能
2、ビデオカード(GF9600GT)からの出力の場合、起動できない
これらは、BIOSで出力先を切り替えて試しています(オンボード、PCI、PCI-Expressの優先順位を設定できるBIOSです)。

3、ビデオカードからの出力で、XPは正常に起動できる

これらから、Linux Mintとビデオカード、の組み合わせで問題が発生していると思われますが、
DVDからのブートの時はビデオカードからの出力でも正常です。

「起動できない」と書きましたが、電源を入れ、起動OSを選んだ後、ディスプレイが「信号なし」となりスリープします。

以下、環境を列記します。(XPのCPUIDで取得したものです)

今回別PC(GF8800GT付き)にもMATE16 64bitを導入しましたが、そちらは順調に動いているのですが・・・
なにかお気づきの事がありましたらご教示いただければ幸いです。宜しくお願いします。
-------------------------------------
Display adapter 0
Name NVIDIA GeForce 9600 GT
Board Manufacturer 0x107D (0x2AC1)
Revision A1
Codename G94
Technology 65 nm
Memory size 1024 MB
Memory bus width 256 bits

-------------------------------------------------------------------------
Mainboard Model MS-7133 (0x0000019B - 0x005F1893)
Chipset

Northbridge Intel i915P/i915G rev. 0E
Southbridge Intel 82801FB (ICH6) rev. 03
Graphic Interface PCI-Express
PCI-E Link Width x16
PCI-E Max Link Width x16
Memory Type DDR
Memory Size 1024 MBytes
Channels Dual
Memory Frequency 160.0 MHz (5:4)
-------------------------------------------------------------------------
Processor 1 ID = 0
Name Intel Pentium 4 640
Codename Prescott
Specification Intel(R) Pentium(R) 4 CPU 3.20GHz
Package (platform ID) Socket 775 LGA (0x4)
CPUID F.4.3
Extended CPUID F.4
Core Stepping N0
Technology 90 nm
Core Speed 3199.8 MHz

ディスプレイ:HP LP2065(オンボードはD-sub、グラフィックカードはDVI接続)
s98545sm | Linux Mint 16 Mate 64bit
家庭のIT http://it-athome.blogspot.jp/
s98545sm
序二段
 
記事: 33
登録日時: 2014年3月07日(金) 21:30
お住まい: 東京都

Re: グラフィックカード関連の問題(インストールから初回起動まで)

投稿記事by hkou » 2014年4月13日(日) 17:20

初めまして。
Linux Mint MATE16 32bitをお使いとのことですからUbuntuベースですね???(DebianベースのLMDEでは無いと思って話を進めます。)

GF9600GTはUbuntuでもいろいろトラブルがあるのか、国内外やたら検索で掛かりますね。

オンボードのグラフィックと双方使える状態にしてから、GF9600GTのLinux用のドライバーを充てたほうがいいかもしれませんね。

投稿された年が2009年と古いのが気になりますが、一応ubuntu日本語フォーラムで似たようなケースがありましたので参考にどうぞ

https://forums.ubuntulinux.jp/viewtopic.php?id=5885

投稿年数が古いのはグラボ自身が古いので、それは仕方が無いのか??ともおもいつつ、無事解決することを願っています。

英語でしたがドライバのInstall How toのサイトもありましたので(現13.10に対応)そちらも参考にしたほうがいいかもしれません。

http://www.howopensource.com/2012/10/in ... using-ppa/
hkou
前相撲
 
記事: 5
登録日時: 2014年4月12日(土) 20:56

Re: グラフィックカード関連の問題(インストールから初回起動まで)

投稿記事by s98545sm » 2014年4月16日(水) 00:27

>>hkouさん

ありがとうございます!頂いた内容で解決できました!

1つ目のリンク先で、2つのモニタに接続していた為に標準のドライバではダメだった、というのがヒントになりました。

今回使用しているモニタにはDVI入力端子が2つあり、前面ボタンで入力1,入力2を切り替える事が出来るようになっていました。
今回、私は
オンボD-sub出力 → 変換ケーブル →モニタDVI入力1
グラボDVI出力 → ケーブル →モニタDVI入力2

と2本のケーブルを繋げっぱなしにして、BIOSで出力の優先順位を設定する方法を取っていました。
※2本繋げた理由は忘れました・・・
オンボの設定は、オンボについては単体で使う設定がありながら、PCIとPCIeについては他の接続との相対的な優先順位を「必ず」設定しなければなりませんでした。
選択肢:オンボのみ、オンボ優先PCIe劣後、PCI優先PCIe劣後、PCIe優先オンボ劣後、PCI優先オンボ劣後、というような感じです。
PCIeから出力するには、別の何かを「優先順位の低い出力先」に選ぶ必要がありました。

頂いたリンク先で、2先へ出力していたのが問題であったケースがあったため、今回それに近い状態になっているのではないかと考え
オンボに繋いでいたD-subケーブルを外したところ、GF9600GT側の出力で正常に起動しました。
※ただし、試行錯誤の過程でオンボ出力で操作しながらnVidia製ドライバもインストールしていましたので、今となっては問題切り分けは判然としません。

i915GとGF9600GTでは、私の用途では差が大きいので本当に助かりました。ありがとうございました。
s98545sm | Linux Mint 16 Mate 64bit
家庭のIT http://it-athome.blogspot.jp/
s98545sm
序二段
 
記事: 33
登録日時: 2014年3月07日(金) 21:30
お住まい: 東京都


Return to インストールと起動

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[2人]

cron