ubuntu13.10がリリースされたけれど・・・

Linux Mintのその他。質問以外も大歓迎です!

ubuntu13.10がリリースされたけれど・・・

投稿記事by umagoro » 2013年10月20日(日) 21:37

Ubuntu13.10がリリースされ、新しいバージョンではIBusが1.5にアップデートされたようですが、これに伴い日本語入力まわりでバグが発生したようですね。
https://wiki.ubuntu.com/SaucySalamander ... jBuihiP8A-

UbuntuベースのLinuxMintの次期バージョンにも影響が出るかも。Cinnamon環境にもどのような影響が出るのかちと不安です。
umagoro
三段目
 
記事: 38
登録日時: 2013年9月19日(木) 23:28

ibus の言語パネルが出ない仕様変更は痛いですねえ…

投稿記事by Emmanuel_Chanel » 2013年12月20日(金) 06:49

このトピックを見た時は、バグという事で、そのうち何とかしてくれるだろうという他人任せさで、自分のブログLinux Mint 16 Petra インストールのエントリーを書いた時には、ここがあるのを覚えてさえいない体たらくでしたが、 ibus の言語パネルが出ない仕様変更は、 Windows 上の X サーバーを使う上で痛いですねえ…
----
Emmanuel Chanel emmanuelchanel@gmail.com
アバター
Emmanuel_Chanel
序二段
 
記事: 27
登録日時: 2012年6月26日(火) 02:11

Fcitxを使うことにしました

投稿記事by ban » 2013年12月24日(火) 09:40

Ibusのバグというより、仕様変更痛いですね。
ネットでも酷評されていますが、完全に改悪ですね。
VMware上でIbus 1.5をテストしましたが、自分にとっては使い物になりません。
私もどう対応しようかとネットで調べたり、VMware上でやってみましたのでその報告です。

先ずIbusのバージョンをを1.42に戻す。これは現実的ではありません。
やろうと思えばソースからコンパイルすることになりそうです。

結局たどり着いたのがIbusの代わりにFcitxを使うことです。
uimやscimも試してみましたが、fcitxが一番快適でした。
ただし、Linux Mint 16 KDE 64bit RCをVMware上で動かしてそこにfcitxをインストールしてみたのですが、変換窓の位置がおかしい。
他にも些細な不具合がありました。
それでもIbus 1.5よりははるかにましで、次にOSをインストールし直すときには、(Linux Mint 16 KDE がリリースされたのでそれにします)、fcitxを使うことにしました。
インストールの方法はここにあります。
http://fu-sen.org/post/69046386632/linux-mint-16-fcitx
Ubuntuの場合とはインストールするパッケージが微妙に違うので注意が必要です。

さらにLinux Mint KDEの場合はまた違います。必要なパッケージは以下です。
fcitx
fcitx-ui-classic
fcitx-mozc
mozc-utils-gui
kde-config-fcitx
fcitx-frontend-qt4 または fcitx-frontend-qt5(たぶんどちらでも良い)
Hiroaki Ban
Linux Mint 16 Perta KDE 64bit
端末入力を楽にする3つの小技
http://forums.linuxmint-jp.net/viewtopic.php?f=10&t=1178
ban
幕下
 
記事: 75
登録日時: 2013年11月04日(月) 01:41

Re: ubuntu13.10がリリースされたけれど・・・

投稿記事by fu-sen » 2014年3月06日(木) 18:18

はじめまして。ふうせん Fu-sen. です。
こちらのフォーラムへ書き込みするのははじめてです。皆様はじめまして。 :P

自分のブログを参考にしていただき、ありがとうございます。
自分は Linux Mint のサイトを製作・公開していまして、KDE の件はそちらに追記させていただきました。
ban さん、ありがとうございます。KDE は gtk ではなくて qt ですもんね。
http://linuxmintjp.jimdo.com/%E6%97%A5% ... %E5%8C%96/

ちなみに Debian Edition でも iBus 1.5 になったようですので、
同様に対応が必要になっています。Fcitx は以前から使えてますので、Fcitx で解決できます。

Ubuntu 14.04 日本語 Remix は iBus 1.5 のままにするか、Fcitx にするか頭を悩ませているようです。
もしかしたら、Linux Mint Japan でも日本語化で Fcitx をデフォルトにする対応を必要とするかもしれません。
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Fcitx を使用している時の問題が解決しました。

投稿記事by fu-sen » 2014年3月07日(金) 18:50

ここをみて Fcitx を入れた人も多いと思うので、あえて返信で行わせていただきます。

Fcitx を今まで使っていて、入力していた文字が候補枠内で表示されていたと思います。
例えば「りなっくすみんと」を入力した時に

fcitxmintdark2.jpg
fcitxmintdark2.jpg (8.29 KiB) 表示数: 24871 回

このように表示されていたんですね。
これの改善方法がわかりました。ソフトウェアの管理や apt-get を用いて、下記を追加でインストールして下さい。

・Cinnamon・MATE・Xfce fcitx-frontend-gtk2 ( 他のサイトで情報を得ている場合は fcitx-frontend-gtk3 )
・KDE fcitx-frontend-gtk2 fcitx-frontend-gtk3 ( fcitx-frontend-qt4 fcitx-frontend-qt5 を片方しかいれなければこれも)

つまり、frontend をほぼ完全に入れるようにします。
その後、一度ログアウトして、ログインしなおして下さい。(再起動でも構いません)
これによって入力中の文字が元のテキスト部分に表示されるようになります。

fcitxgtk.jpg
fcitxgtk.jpg (8.3 KiB) 表示数: 24871 回

これでより快適にご利用いただけるでしょう。お試しください。 :D
最後に編集したユーザー fu-sen [ 2014年3月09日(日) 03:58 ], 累計 1 回
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Re: Fcitx を使用している時の問題が解決しました。

投稿記事by lindwurm » 2014年3月08日(土) 12:38

fu-sen さんが書きました: ・Cinnamon・MATE・Xfce fcitx-frontend-gtk2
・KDE fcitx-frontend-gtk2 fcitx-frontend-gtk3 ( fcitx-frontend-qt4 fcitx-frontend-qt5 を片方しかいれなければこれも)


CinnamonはGTK+3を使用しているので、必要になるのは fcitx-frontend-gtk3 だと思うのですが…




==以下、必要な方のみ==
あと、Linux Mint 16 では推奨パッケージのインストールが行われないので端末からは --install-recomended オプションを付けたほうが良いかも知れません。
( fcitx-frontend-gtk3 の推奨パッケージに fcitx-frontend-gtk2 があるので,CinnamonやKDEの場合は fcitx-frontend-gtk3 を指定するだけで済みます)

--install-recomended オプションを毎回付けて実行するのが面倒な方は、推奨パッケージのインストールを有効化することで(再インストール等を行わない限り)、
Linux Mint 15まで及びUbuntuと同じ、推奨パッケージのインストールが行われる挙動に戻すことができます。

去年12月のLinux Mint Advent Calendarにおいてblogで手短に説明していますが、必要であればスクリーンショットをつけるなり、もう少し丁寧に説明しようと思います。
ておくれブログ: 補足 [Linux Mint Advent Calendar 18日目]
当該ユーザーは現在活動していません
lindwurm
三段目
 
記事: 41
登録日時: 2013年4月04日(木) 21:34

Re: Fcitx を使用している時の問題が解決しました。

投稿記事by fu-sen » 2014年3月08日(土) 12:43

あっ、モードちゃんだ。お久しぶりです! ←いや、モードちゃんではないぞ
Twitter ではどうも〜。って自分が誰か分かるでしょうか。ワンワン!

lindwurm さんが書きました:CinnamonはGTK+3を使用しているので、必要になるのは fcitx-frontend-gtk3 だと思うのですが…

……と思って今までは fcitx-frontend-gtk3 だけを紹介していたのですが、それがダメだったんですね〜。 :x
フルに入れる必要があったのです。おそらく個々のアプリに適応する frontend が必要なのだと思われます。
まぁ、頭で想像するより、実際に試せば分かる事です。
わざわざ画像まで付けて投稿しているという事は、実際に行ってそうなった事実を投稿しているのですよ。
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Re: Fcitx を使用している時の問題が解決しました。

投稿記事by lindwurm » 2014年3月09日(日) 02:05

fu-senさんなら理解できると思いますので下手に丁寧に書いたりせずざっくり説明させていただきます。

以下の内容は他のユーザーによって読まれることを想定しないものです。
他の方からの当該内容に関する質問への私からの回答については期待しないでください。これでも一身上の理由から活動休止中の身です。


fu-sen さんが書きました:
lindwurm さんが書きました:CinnamonはGTK+3を使用しているので、必要になるのは fcitx-frontend-gtk3 だと思うのですが…

……と思って今までは fcitx-frontend-gtk3 だけを紹介していたのですが、それがダメだったんですね〜。 :x
フルに入れる必要があったのです。おそらく個々のアプリに適応する frontend が必要なのだと思われます。
まぁ、頭で想像するより、実際に試せば分かる事です。
わざわざ画像まで付けて投稿しているという事は、実際に行ってそうなった事実を投稿しているのですよ。


ちょっと勘違いされているようなので説明すると、先の投稿及び http://packages.ubuntu.com/saucy/fcitx-frontend-gtk3 にもある通り、
fcitx-frontend-gtk3 には推奨パッケージとして fcitx-frontend-gtk2 が指定されています。

Ubuntuの場合は fcitx-frontend-gtk3 をインストールする際に同時に入りますが、Linux Mint 16では推奨パッケージのインストールが行われない仕様に
なっているため、端末からだと --install-recomended オプションを付加するか、常に推奨パッケージをインストールさせるように設定する必要が有ります。

(この例として、Linux Mint Japan のWebサイトに記載している日本語化の手順にも、mint-gnome-jamint-kde-ja といったメタパッケージの中では
指定されていないものの、そこに含まれる ibus-mozc などの推奨パッケージである mozc-utils-gui をインストールするために --install-recomended
オプションを指定しています。)

さて、話が遠回りしましたが、要するに私が言いたかったのは

fu-sen さんが書きました:これの改善方法がわかりました。ソフトウェアの管理や apt-get を用いて、下記を追加でインストールして下さい。

・Cinnamon・MATE・Xfce fcitx-frontend-gtk2
・KDE fcitx-frontend-gtk2 fcitx-frontend-gtk3 ( fcitx-frontend-qt4 fcitx-frontend-qt5 を片方しかいれなければこれも)


において、Cinnamonは fcitx-frontend-gtk2 だけじゃなくて fcitx-frontend-gtk3 も必要ですよね、ということだけです。
(そして個人的にはLinux Mint 16のこの仕様が非常に面倒臭いということです)

それと、私もfcitx周りは手元の環境でもビルドするなどして試していたので、私の投稿も決して頭の中での想像ではなく
事実に基づいているということを理解いただければ幸いです。
当該ユーザーは現在活動していません
lindwurm
三段目
 
記事: 41
登録日時: 2013年4月04日(木) 21:34

Re: Fcitx を使用している時の問題が解決しました。

投稿記事by fu-sen » 2014年3月09日(日) 02:47

lindwurm さんが書きました:要するに私が言いたかったのは

fu-sen さんが書きました:これの改善方法がわかりました。ソフトウェアの管理や apt-get を用いて、下記を追加でインストールして下さい。

・Cinnamon・MATE・Xfce fcitx-frontend-gtk2
・KDE fcitx-frontend-gtk2 fcitx-frontend-gtk3 ( fcitx-frontend-qt4 fcitx-frontend-qt5 を片方しかいれなければこれも)


において、Cinnamonは fcitx-frontend-gtk2 だけじゃなくて fcitx-frontend-gtk3 も必要ですよね、ということだけです。
(そして個人的にはLinux Mint 16のこの仕様が非常に面倒臭いということです)

いいえ。

http://fu-sen.org/post/69046386632/linux-mint-16-fcitx

元々ご参照いただいているこの記事ではすでに fcitx-frontend-gtk3 が含まれています。
(逆にいうと MATE でも fcitx-frontend-gtk3 を指定していました。これは中国のサイトから当時情報を得てのものです)

で、波動の違いも感じています。
Debian Edition では UP7 で fcitx を入れた時に従来公開していた状態で入力時のテキスト部分が表示されていたのですが、
UP8 になって 16 と同じ対応が必要になっています。
最後に編集したユーザー fu-sen [ 2014年3月09日(日) 03:02 ], 累計 1 回
fu-sen
関脇
 
記事: 364
登録日時: 2014年3月06日(木) 17:40

Re: Fcitx を使用している時の問題が解決しました。

投稿記事by lindwurm » 2014年3月09日(日) 03:01

fu-sen さんが書きました:
lindwurm さんが書きました:要するに私が言いたかったのは

fu-sen さんが書きました:これの改善方法がわかりました。ソフトウェアの管理や apt-get を用いて、下記を追加でインストールして下さい。

・Cinnamon・MATE・Xfce fcitx-frontend-gtk2
・KDE fcitx-frontend-gtk2 fcitx-frontend-gtk3 ( fcitx-frontend-qt4 fcitx-frontend-qt5 を片方しかいれなければこれも)


において、Cinnamonは fcitx-frontend-gtk2 だけじゃなくて fcitx-frontend-gtk3 も必要ですよね、ということだけです。
(そして個人的にはLinux Mint 16のこの仕様が非常に面倒臭いということです)

いいえ。

http://fu-sen.org/post/69046386632/linux-mint-16-fcitx

元々ご参照いただいているこの記事ではすでに fcitx-frontend-gtk3 が含まれています。


私が指摘しているのはこのトピックにおける5つ目のレスに於ける単なる記載ミスのことです.
当該ユーザーは現在活動していません
lindwurm
三段目
 
記事: 41
登録日時: 2013年4月04日(木) 21:34

次へ

Return to その他

オンラインデータ

このフォーラムを閲覧中のユーザー: なし & ゲスト[1人]